[RESOLVED] The 1.19 Release Candidate and You

We accidentally offered the 1.19 Release Candidate viewer before it was ready to be downloaded! This download has been removed for the time being and we will be let you know as soon as it becomes available. — Frontier

🙂

The 1.19 Release Candidate is not currently operational… as such, please do not attempt to upgrade to this version as it will force a downgrade to 1.18.6. The issues are being addressed currently and should be resolved fairly soon.

We apologize for any inconvenience this has caused.

This entry was posted in Announcements & News, Customer Service, New Releases. Bookmark the permalink.